Crashing on attaching 3rd party Midi sequencer/arpeggiators

Post your bug reports/problems here

Moderators: davidv, seb@plogue

lnikj
Posts: 2
Joined: Sun Oct 29, 2006 2:26 pm

Crashing on attaching 3rd party Midi sequencer/arpeggiators

Postby lnikj » Fri Jun 23, 2017 1:40 am

Hi

I have a reproducible bug.

Third party AU midi sequencers and arpeggiators are crashing Bidule. For example, Monoplugs’ B-Step Sequencer, Kirnu Cream, Audio Vitamins’ Stochas, Xfer’s Cthulhu. It happens in the standalone and the plugins.

To reproduce, attach any synth to the audio output and then attach one of the above to the midi input of the synth. Crash.

Alternatively, attach one of the above to the midi input of any synth, and then attach the synth to the audio output. Crash.

Late 2011 MacBook Pro, 10.11.6, latest version of Bidule.

Crash report attached.
Attachments
Plogue Bidule_2017-06-23-072612_MBP.crash
(65.42 KiB) Downloaded 9 times

seb@plogue
Site Admin
Posts: 9592
Joined: Tue Mar 02, 2004 7:23 pm
Location: Montreal
Contact:

Re: Crashing on attaching 3rd party Midi sequencer/arpeggiators

Postby seb@plogue » Fri Jun 23, 2017 9:43 am

Seems to be related to the fake audio buffer that needs to be there when calling an AU MIDI Processor, that used to work.

I can reproduce here and I'm looking into it.

lnikj
Posts: 2
Joined: Sun Oct 29, 2006 2:26 pm

Re: Crashing on attaching 3rd party Midi sequencer/arpeggiators

Postby lnikj » Fri Jun 23, 2017 9:50 am

Thanks Seb :)


Return to “Bidule Bugs and Problems”

Who is online

Users browsing this forum: No registered users and 2 guests