visual studio versions

Discussion about the Bidule SDK, post your questions, feature request and plugins here.

Moderators: davidv, seb@plogue

dts350z
Posts: 1521
Joined: Thu Jan 15, 2009 1:18 pm

visual studio versions

Postby dts350z » Fri Feb 25, 2011 6:27 pm

I've been using visual studio express 2008 C++ to make my plugins.

Now one of my machines has the full version of visual studio 2008.

When I build the plugin I'm working on with express, it works fine, with the full version Plogue crashes when you add the plugin to a layout.

Fortunately, I can still use both versions of visual studio, but any idea what's up?

Himm, maybe I should try "release", vs. "debug" and see if there is still a problem.

seb@plogue
Site Admin
Posts: 9592
Joined: Tue Mar 02, 2004 7:23 pm
Location: Montreal
Contact:

Re: visual studio versions

Postby seb@plogue » Sat Feb 26, 2011 7:16 am

If it crashes when adding it to the layout, it does seem to suggest something in the code rather than anything related to runtime, you should try debugging.

dts350z
Posts: 1521
Joined: Thu Jan 15, 2009 1:18 pm

Re: visual studio versions

Postby dts350z » Sat Feb 26, 2011 11:48 am

The crash is in plogue, memory allocation error. The log file ends abruptly after the openGL stuff, with no error listed.

seb@plogue
Site Admin
Posts: 9592
Joined: Tue Mar 02, 2004 7:23 pm
Location: Montreal
Contact:

Re: visual studio versions

Postby seb@plogue » Mon Feb 28, 2011 9:50 am

I need to double-check but I don't think there is much logging going on outside of error cases in the Bidule SDK loading/init.
At this point, you should really fire up the debugger and see where it ends up.


Return to “Bidule SDK”

Who is online

Users browsing this forum: No registered users and 3 guests