Chipsounds in Renoise

General discussion about chipsounds

Moderators: eric_telemaque, davidv, seb@plogue

martialmonk
Posts: 4
Joined: Fri Nov 18, 2011 11:01 am

Chipsounds in Renoise

Postby martialmonk » Fri Nov 18, 2011 11:56 am

I am experimenting with the chiptunes demo in Renoise to see if I want it, and it definitely sounds AWESOME!

However, I don't know if it's just me, but I can't seem to do the acrobatics I would like to do with it. Nothing too fancy, but stuff like sliding up to a note (while some of the other notes in the same sequence do not portamento). It seems like it would take an incredibly complex and intimate interface to get Renoise and Chipsounds to work together like that, but at the same time, such effects are pretty essential in chiptunes. Any suggestions?

Thanks and cheers!

davidv
Site Admin
Posts: 1567
Joined: Tue Mar 02, 2004 7:23 pm
Contact:

Re: Chipsounds in Renoise

Postby davidv » Fri Nov 18, 2011 1:25 pm

I would say use a single voice per channel, and send pitchbends on each channel.
This would mirror the functionality of each chip.

... and thanks for the 'awesome' part.!
David Viens,
Plogue Art et Technologie Inc. Montreal.
http://www.plogue.com

martialmonk
Posts: 4
Joined: Fri Nov 18, 2011 11:01 am

Re: Chipsounds in Renoise

Postby martialmonk » Fri Nov 18, 2011 4:18 pm

Thank you for replying davidv!

I tried that, and maybe I did it wrong, but I could not get it to always slide up from the note I wanted it to. The note that the portamento slides from is the last note played on that voice. If that's not the note I want it to come from, say if the previous note is an unportamentoed note from another voice, I can't get it to take off from the right note. Any suggestions on how to make that work?

Thanks again!

martialmonk
Posts: 4
Joined: Fri Nov 18, 2011 11:01 am

Re: Chipsounds in Renoise

Postby martialmonk » Sat Nov 19, 2011 1:57 am

Ah! I got it! I managed to figure it out! I'm not sure precisely why it works yet, but I will.

Thanks again for your time davidv!

martialmonk
Posts: 4
Joined: Fri Nov 18, 2011 11:01 am

Re: Chipsounds in Renoise

Postby martialmonk » Thu Nov 22, 2012 12:56 am

Hello,
Almost exactly a year from my last post, here I am again!

I haven't worked on chiptunes in a while, and since coming back, both Chipsounds and Renoise have upgraded! Great for improvement, bad for figuring out how to do this again. Here's my troubleshooting trying to get one note to slide together in the middle of a line:
1. I got Renoise to register and play nicely with Chipsounds. The only thing missing is the ability to slide from one note to another.
2. The MIDI command "M0" bends the pitch, but everything after that is affected as well.
3. Using more than one channel creates a break between the notes that are involved in the slide. I can make it sound like it is sliding from one note to another, but not the same instrument sliding from one note to another.
4. I cannot use the external VST interface, because I would either have to have all of the notes slide into one another, or I would have to use another channel, creating the problem noted above.

Once again, I must ask for advice. Is there any way to do this, perhaps a new feature or an old secret piece of wisdom?
Thanks in advance!


Return to “chipsounds General”

Who is online

Users browsing this forum: No registered users and 1 guest