Random semitone transposition

Post your bug reports/problems here

Moderators: eric_telemaque, davidv, seb@plogue

Shadowfire
Posts: 7
Joined: Fri Jul 13, 2012 8:57 am

Random semitone transposition

Postby Shadowfire » Fri Jul 13, 2012 10:33 am

Just bought chipsounds yesterday (really enjoying it, expecting it to be that "secret ingredient" in a lot of mixes that needed something unique). I'm getting one really aggravating problem with the RP2A03 (NTSC), of which I am running many instances. Occasionally and seemingly randomly, the pitch will start coming out one semitone too high. I'm positive this isn't in the automation, and the trans value in the controls tab doesn't visibly change. I'll set it to -1 to compensate, only to have it go back to normal (and therefore then be a semitone too low) a few plays later. I can't figure out how to reproduce it reliably.

I'm using Logic 9 on OS X 10.7.4 . Any help would be really appreciated as it's happening often enough to really slow down my workflow.

Shadowfire
Posts: 7
Joined: Fri Jul 13, 2012 8:57 am

Re: Random semitone transposition

Postby Shadowfire » Fri Jul 13, 2012 4:44 pm

Apparently setting the bend range to "off" solved this, as well as another issue (that I thought was unrelated) where everything was about 25 cents too high. Any idea why that might be the cause? I'd definitely prefer to be able to send pitch bend messages.

davidv
Site Admin
Posts: 1567
Joined: Tue Mar 02, 2004 7:23 pm
Contact:

Re: Random semitone transposition

Postby davidv » Mon Jul 16, 2012 10:31 am

Shadowfire wrote:Apparently setting the bend range to "off" solved this, as well as another issue (that I thought was unrelated) where everything was about 25 cents too high. Any idea why that might be the cause? I'd definitely prefer to be able to send pitch bend messages.


The thing is that chipsounds remembers the last received pitchbend message, exactly for the reason of automation, thats what is happening.
David Viens,
Plogue Art et Technologie Inc. Montreal.
http://www.plogue.com

Shadowfire
Posts: 7
Joined: Fri Jul 13, 2012 8:57 am

Re: Random semitone transposition

Postby Shadowfire » Wed Jul 25, 2012 10:44 pm

Quite curious. I wonder why it's getting those pitchbend messages at all. Thanks for the diagnosis at any rate, I'll see if I can find the source.


Return to “chipsounds Bugs and Problems”

Who is online

Users browsing this forum: No registered users and 1 guest