Weird portamento behaviour

Post your bug reports/problems here

Moderators: eric_telemaque, davidv, seb@plogue

loveaurell
Posts: 2
Joined: Sat Feb 23, 2013 7:49 am

Weird portamento behaviour

Postby loveaurell » Sat Feb 23, 2013 8:45 am

Hi!

I have programmed a melody in Cubase that looks like this, (The blue block extends the portamento time at that point):
Image
It sounds like this: https://dl.dropbox.com/u/2369149/examples/weird_portamento.wav
I played the same line in another vsti and it sounds like this: https://dl.dropbox.com/u/2369149/examples/expected_portamento.wav

Why doesn't the second last note smoothly fall down to the last one until it's cut off? Is this the way the NES' sound chip works? I expected it to sound like one whole note, bended down at the end, but somehow you can hear the last note's attack before it starts to glide down.

If this is the way it's supposed to sound, is there another way to get the effect I want? Is there some way you could make the pitch envelope fall down on release without having to move up on attack first? I don't like pitchbend, because of the pitch shift resolution and because it's hard to get it natural and to program it in an easy way.

Thanks for your time!

davidv
Site Admin
Posts: 1567
Joined: Tue Mar 02, 2004 7:23 pm
Contact:

Re: Weird portamento behaviour

Postby davidv » Mon Feb 25, 2013 9:44 am

chipsounds retriggers ADSR at each new note, its not a a feature of the NES chip per se, there is no standard for this.

I would suggest to insert pitch bend at the end of the last note, instead of re triggering it.

Note the :"expected_portamento" sounds horribly aliased :)
David Viens,
Plogue Art et Technologie Inc. Montreal.
http://www.plogue.com

loveaurell
Posts: 2
Joined: Sat Feb 23, 2013 7:49 am

Re: Weird portamento behaviour

Postby loveaurell » Tue Feb 26, 2013 5:18 am

Hi David, thanks for the answer.

That explains a lot. Is it planned to make some kind of legato-mode? I don't like working with pitch-bend :)
Yeah I know it sounds quite bad, but in a nice way :)

davidv
Site Admin
Posts: 1567
Joined: Tue Mar 02, 2004 7:23 pm
Contact:

Re: Weird portamento behaviour

Postby davidv » Tue Feb 26, 2013 8:59 am

loveaurell wrote:Hi David, thanks for the answer.
That explains a lot. Is it planned to make some kind of legato-mode? I don't like working with pitch-bend :)


2.0 would have that I'm pretty sure, since it would be based on a different 'engine'.

loveaurell wrote:Yeah I know it sounds quite bad, but in a nice way :)


I like 'accurate' noise myself ;)
David Viens,

Plogue Art et Technologie Inc. Montreal.

http://www.plogue.com


Return to “chipsounds Bugs and Problems”

Who is online

Users browsing this forum: No registered users and 1 guest