Instruments suddenly ignoring velocity

Post your bug reports/problems here

Moderators: eric_telemaque, davidv, seb@plogue

oskaralex
Posts: 2
Joined: Sat Jan 04, 2014 8:33 am

Instruments suddenly ignoring velocity

Postby oskaralex » Sun Jan 05, 2014 4:34 am

Hello!

I'm enjoying the hell out of chipsounds, but yesterday I came across a problem. I'd been editing the velocity of all my notes using the piano roll in Logic Pro 9, to get the phrasing right. I was quite happy with the result, but when I started working on the project again yesterday morning, something wasn't right. I realized that all my instruments had completely stopped responding to the velocity information I'd given them. When I change a note from the lowest to the highest velocity, it still plays at the exact same volume. I'm still baffled and I've tried a few things to rule out some stuff.

1. It's not region based, the MIDI Thru 'Dynamics' is set to 100%, not Fixed.
2. If I go to a chipsounds instance and add another waveform within it, THAT channel alone responds to velocity, the ones that were already there (within the same instance) will not.
3. I made a snap-shot of one of the channels which does not respond to velocity and imported it into a brand new clean project with just one chipsounds instance (a new one). It doesn't respond to velocity either.

This is driving me crazy, I can't figure out what is causing individual channels to ignore velocity information, especially since it was working fine a day ago. I attached the snapshot I made, hopefully you can check it out and see where I'm going wrong. :)

Thanks in advance!
O

https://www.dropbox.com/s/3sddoz0yhm4qo ... %201.ariax

davidv
Site Admin
Posts: 1567
Joined: Tue Mar 02, 2004 7:23 pm
Contact:

Re: Instruments suddenly ignoring velocity

Postby davidv » Mon Jan 06, 2014 11:09 am

Hi

The DMG Wave never responded to velocity by design, since it already uses all the DAC amplitude steps to generate its 4bit waveform.
its not a sudden thing, more than it depends on the waveform.

I could add a version of that patch that allows midi velocity, but it wouldn't be "as per hardware" anymore.
Trouble is all those "(unlimited)" variants were designed to be unlimited on the pitch side, but not on the amplitude side.

If you want you can hack away at a text
{your install dir}\Programs\01. Pure Chip\DMG.sfz

and remove line 75:
amp_veltrack=0 //-> fixed volume still no emulation of FF1C's bits 6 and 5

As you probably see the hardware does support some form of volume on the WAVE channel, but it does so by removing steps, which does alter the timbre, so I didn't implement it.
David Viens,
Plogue Art et Technologie Inc. Montreal.
http://www.plogue.com

oskaralex
Posts: 2
Joined: Sat Jan 04, 2014 8:33 am

Re: Instruments suddenly ignoring velocity

Postby oskaralex » Mon Jan 06, 2014 1:33 pm

Hi Dave!

Embarassing... I must have been editing the veloticies with a Pulse wave instrument and then switched over to Wave and forgotten about it. Thanks for clearing it up! :)

O


Return to “chipsounds Bugs and Problems”

Who is online

Users browsing this forum: No registered users and 2 guests