VC++ Runtime Library Error R6034-Solved

Post your bug reports/problems here

Moderators: davidv, seb@plogue

Posts: 57
Joined: Sat May 15, 2010 7:23 am

VC++ Runtime Library Error R6034-Solved

Postby ForestCat » Sat Mar 14, 2015 2:39 pm

XP SP3, 32bit

I gather that this is a somewhat generic error. I've been installing/uninstalling s/w on this laptop. It's difficult to say at what point this became an issue since I wasn't trying to start bidule at every change.

Does anyone have any idea what might be causing this? I temporarily removed all the VSTs from this laptop to see if that was the issue, no difference. Reinstalled the VC++ 2005, 2008, 2010 runtimes. No difference. At some point during this, XP SP3 was installed.

Is there a safe way to remove every trace of every Visual C and DotNet runtime and reinstall them without making this worse?

Thanks for any help.

EDIT: As it turns out, uninstalling the VC++ Runtimes from Add/Remove Programs DOES NOT remove them from System32, where they may have been deposited by well-meaning older app installers, etc.
Yes, I use Windows because I like pain. :-)
The proper location for these dlls is in the WinSxS/blah, where mulitple versions exist "Side by Side"(hopefully) avoiding dll version conflicts. In my case there was a msvcp90.dll in system32 causing the bloodshed. Deleted it, no more error in Bidule. Now, to see what that broke, lol.

Return to “Bidule Bugs and Problems”

Who is online

Users browsing this forum: No registered users and 0 guests