Main menu/Menubar

File Menu

  • New: starts a new layout
  • Open: opens an existing layout
  • Import: opens an existing layout and attempts to merge it into the current one
  • Recent Files: lists recently used .bidule files
  • Clear File History: removes all files under the Recent Files menu
  • Save: saves the current layout to its existing location (or a new one if it does not have one)
  • Save As: saves the current layout to a new location
  • Save Copy: saves a copy the current layout to a location, this will not change the default location of the layout

Edit Menu

  • Undo: undoes the last action
  • Redo: redo the last undo
  • Cut: cuts the selection
  • Copy: copies the selection to clipboard
  • Paste: pastes the contents of the clipboard in the current layout
  • Copy+Paste: copies and pastes selection in a single command
  • Auto-save: enables auto-saving the current layout every 5 minutes for the session (the time can be changed manually through the registry or defaults CLI)
  • Offline: toggles offline mode:
    Offline mode
    Toggles Offline mode On/Off (default is Off)

    The Offline mode was added to Bidule so that it could be used to

    • Render audio to disk faster than realtime, when the graph takes less than 100% cpu in normal use
    • Render stutter-free audio to disk, when the graph takes more than 100% cpu usage in normal use.

    You cannot use an audio device (input or output) in Offline mode. In almost all cases, you will use an Audio File Recorder bidule (or more than one) instead to record the offline output.

    When using the Offline mode, you will notice that the standard cpu gauge has been replaced by an elapsed time meter, which should give you an estimate of the speed at which the render is done.

  • Scan Plugins: rescans VST and AU plugins from scratch
  • Scan Groups: rescans groups from scratch
  • Update Plugins and Groups: scans for new plugins and groups (same as when starting up)
  • Reset History: resets the count for the History tab of the Palette
  • Set current patch as default: saves the current layout as the default (i.e. you will get this each time you startup and each time a new layout is created), each mode (standalone, ReWire, VST, AU) has its own default layout.

Tools Menu

  • MediaPool: toggles the display of the MediaPool window
  • Parameters: toggles the display of the Parameters window
  • Palette: toggles the display of the Palette window
  • Groups Manager: toggles the display of the Group Manager window
  • ReWire Devices Config
    ReWire Devices Config

    The ReWire Devices configuration dialog lets you specify defaults number of MIDI inputs/outputs, number of audio outputs and if the ReWire application should be launch/closed automatically. Use this to set up as many MIDI inputs you want for a ReWire device or restrain the number of audio outputs to only 2 if you only want to have the master output. If you have multiple layouts using ReWire devices and you want to be able to quickly change between them, make sure to un-check the auto-launch option, this will keep the ReWire application opened and it will be ready to use as soon as the layout is loaded.

  • OSC Server: toggles the display of the OSC Server window, this is where the entire OSC address space for the current layout is displayed
  • OSC Client: toggles the display of the OSC Client window, this is where OSC servers (i.e. where OSC messages are sent) are managed
  • OSC Monitor: toggles the display of the OSC Monitor window, the OSC Monitor is used to log all incoming and outgoing OSC messages
  • Find: finds a bidule by display name in the current group